Riporto qui di seguito la segnalazione di Sandro riguardo il presunto bug dell’installazione di LeenO. E’ l’occasione per chiarire a tutti le modalità di risoluzione.

Buon giorno, voglio provare il vostro software, ma durante l’installazione dell’estensione in LibreOffice su ambiente Linux il sistema mi riporta il seguente errore:

Failed to register package for vnd.sun.star.expand:$UNO_USER_PACKAGES_CACHE/uno_packages/lu13594i357nc.tmp_/LeenO-3.11.2-150402220104.oxt/pyLeenO

Ho provato ad aggiornare Libre Office alla versione 5 ma il problema non si risolve.

Grazie in anticipo per una eventuale risposta.

Sandro


Ciao Sandro,
quello di cui parli, e che ha riscontrato anche qualcun altro, non è propriamente un errore, ma dipende dalla mancata installazione del bridge Python-UNO che permette a LibreOffice di leggere ed interpretare il linguaggio Python con cui sono scritte alcune porzioni di LeenO.

Sotto GNU/Linux, perché LeenO funzioni correttamente, dovrai installare il pacchetto python3-uno che solitamente è disponibile per tutte le distribuzioni. Puoi installarlo col gestore di pacchetti a corredo della tua distribuzione.

Nel caso utilizzi una derivata di Debian, da shell digita quanto segue:

$ sudo apt-get install python3-uno libreoffice-script-provider-python
(*)

Dopo potrai installare LeenO semplicemente avviando il pacchetto preso da questo sito con un doppio click oppure trascinandolo su di una finestra di LibreOffice.

Trovi altre informazioni su https://pypi.python.org/pypi/unotools


(*) Ed aggiungo libreoffice-script-provider-python” (provider di scripting Python) proprio per via della segnalazione di Sandro che ringrazio.